Getting TP-Link WN722N to work on RPi OpenWRT












3














I'm trying to create my own wireless router using a Raspberry Pi 2 and a TP-Link WN722N. I have OpenWRT running off the MicroSD card and I have installed LuCI, but I need to install the wireless card drivers via SSH. I've tried following the directions here:
OpenWrt → General Discussion → how to enable WN722N (AR9271) wifi usb on MR3020 ?



While the USB card is inserted, I install the drivers, then create the wireless interface:



# install drivers
opkg install kmod-ath9k-htc

# create wireless wan interface
uci set network.wwan=interface
uci set network.wwan.proto=dhcp
uci set network.wwan.hostname="$STATION"
uci commit network


But when I attempt to enable the wifi interface, UCI gives me an Entry not found error. Every piece of advice I've read is to check /etc/config/wireless for the adapter's settings, but this file does not exist. This probably means that the adapter is not being recognized, but I am able to do this:



root@OpenWrt:~# wifi detect
config wifi-device radio0
option type mac80211
option channel 11
option hwmode 11g
option path 'platform/bcm2708_usb/usb1/1-1/1-1.5/1-1.5:1.0'
option htmode HT20
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 1

config wifi-iface
option device radio0
option network lan
option mode ap
option ssid OpenWrt
option encryption none

root@OpenWrt:~# lsusb
Bus 001 Device 004: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


So clearly, the RPi is seeing the USB wireless adapter but it is not generating an /etc/config/wireless file. What am I doing wrong?



Any help appreciated, thanks!










share|improve this question
























  • Do iw list to see the list of detected wireless devices. You also have a Broadcom USB wireless stick connected. Is this intended?
    – qasdfdsaq
    Nov 5 '15 at 14:31


















3














I'm trying to create my own wireless router using a Raspberry Pi 2 and a TP-Link WN722N. I have OpenWRT running off the MicroSD card and I have installed LuCI, but I need to install the wireless card drivers via SSH. I've tried following the directions here:
OpenWrt → General Discussion → how to enable WN722N (AR9271) wifi usb on MR3020 ?



While the USB card is inserted, I install the drivers, then create the wireless interface:



# install drivers
opkg install kmod-ath9k-htc

# create wireless wan interface
uci set network.wwan=interface
uci set network.wwan.proto=dhcp
uci set network.wwan.hostname="$STATION"
uci commit network


But when I attempt to enable the wifi interface, UCI gives me an Entry not found error. Every piece of advice I've read is to check /etc/config/wireless for the adapter's settings, but this file does not exist. This probably means that the adapter is not being recognized, but I am able to do this:



root@OpenWrt:~# wifi detect
config wifi-device radio0
option type mac80211
option channel 11
option hwmode 11g
option path 'platform/bcm2708_usb/usb1/1-1/1-1.5/1-1.5:1.0'
option htmode HT20
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 1

config wifi-iface
option device radio0
option network lan
option mode ap
option ssid OpenWrt
option encryption none

root@OpenWrt:~# lsusb
Bus 001 Device 004: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


So clearly, the RPi is seeing the USB wireless adapter but it is not generating an /etc/config/wireless file. What am I doing wrong?



Any help appreciated, thanks!










share|improve this question
























  • Do iw list to see the list of detected wireless devices. You also have a Broadcom USB wireless stick connected. Is this intended?
    – qasdfdsaq
    Nov 5 '15 at 14:31
















3












3








3


1





I'm trying to create my own wireless router using a Raspberry Pi 2 and a TP-Link WN722N. I have OpenWRT running off the MicroSD card and I have installed LuCI, but I need to install the wireless card drivers via SSH. I've tried following the directions here:
OpenWrt → General Discussion → how to enable WN722N (AR9271) wifi usb on MR3020 ?



While the USB card is inserted, I install the drivers, then create the wireless interface:



# install drivers
opkg install kmod-ath9k-htc

# create wireless wan interface
uci set network.wwan=interface
uci set network.wwan.proto=dhcp
uci set network.wwan.hostname="$STATION"
uci commit network


But when I attempt to enable the wifi interface, UCI gives me an Entry not found error. Every piece of advice I've read is to check /etc/config/wireless for the adapter's settings, but this file does not exist. This probably means that the adapter is not being recognized, but I am able to do this:



root@OpenWrt:~# wifi detect
config wifi-device radio0
option type mac80211
option channel 11
option hwmode 11g
option path 'platform/bcm2708_usb/usb1/1-1/1-1.5/1-1.5:1.0'
option htmode HT20
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 1

config wifi-iface
option device radio0
option network lan
option mode ap
option ssid OpenWrt
option encryption none

root@OpenWrt:~# lsusb
Bus 001 Device 004: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


So clearly, the RPi is seeing the USB wireless adapter but it is not generating an /etc/config/wireless file. What am I doing wrong?



Any help appreciated, thanks!










share|improve this question















I'm trying to create my own wireless router using a Raspberry Pi 2 and a TP-Link WN722N. I have OpenWRT running off the MicroSD card and I have installed LuCI, but I need to install the wireless card drivers via SSH. I've tried following the directions here:
OpenWrt → General Discussion → how to enable WN722N (AR9271) wifi usb on MR3020 ?



While the USB card is inserted, I install the drivers, then create the wireless interface:



# install drivers
opkg install kmod-ath9k-htc

# create wireless wan interface
uci set network.wwan=interface
uci set network.wwan.proto=dhcp
uci set network.wwan.hostname="$STATION"
uci commit network


But when I attempt to enable the wifi interface, UCI gives me an Entry not found error. Every piece of advice I've read is to check /etc/config/wireless for the adapter's settings, but this file does not exist. This probably means that the adapter is not being recognized, but I am able to do this:



root@OpenWrt:~# wifi detect
config wifi-device radio0
option type mac80211
option channel 11
option hwmode 11g
option path 'platform/bcm2708_usb/usb1/1-1/1-1.5/1-1.5:1.0'
option htmode HT20
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 1

config wifi-iface
option device radio0
option network lan
option mode ap
option ssid OpenWrt
option encryption none

root@OpenWrt:~# lsusb
Bus 001 Device 004: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


So clearly, the RPi is seeing the USB wireless adapter but it is not generating an /etc/config/wireless file. What am I doing wrong?



Any help appreciated, thanks!







wireless-networking raspberry-pi openwrt






share|improve this question















share|improve this question













share|improve this question




share|improve this question








edited Dec 9 '16 at 13:46









Hennes

58.9k792141




58.9k792141










asked Oct 28 '15 at 20:45









user3617429user3617429

1612




1612












  • Do iw list to see the list of detected wireless devices. You also have a Broadcom USB wireless stick connected. Is this intended?
    – qasdfdsaq
    Nov 5 '15 at 14:31




















  • Do iw list to see the list of detected wireless devices. You also have a Broadcom USB wireless stick connected. Is this intended?
    – qasdfdsaq
    Nov 5 '15 at 14:31


















Do iw list to see the list of detected wireless devices. You also have a Broadcom USB wireless stick connected. Is this intended?
– qasdfdsaq
Nov 5 '15 at 14:31






Do iw list to see the list of detected wireless devices. You also have a Broadcom USB wireless stick connected. Is this intended?
– qasdfdsaq
Nov 5 '15 at 14:31












2 Answers
2






active

oldest

votes


















0














It doesn't create the file to avoid configuration overlapping.



You must append on the file the detected configuration.



Use: wifi detect > /etc/config/wireless instead.



Hope it helps others.






share|improve this answer





























    0














    did you insert the usb into a different usb slot? regarding option path: the 5 in the 1.5 is the usb slot id. if you pulled it out of the initial one, and put it into another slot, then you would need to manually update that to the new id. There may be a cli/shell command to do this, and perhaps that what the previous answer by CuSS would achieve with wifi detect > /etc/config/wireless






    share|improve this answer





















      Your Answer








      StackExchange.ready(function() {
      var channelOptions = {
      tags: "".split(" "),
      id: "3"
      };
      initTagRenderer("".split(" "), "".split(" "), channelOptions);

      StackExchange.using("externalEditor", function() {
      // Have to fire editor after snippets, if snippets enabled
      if (StackExchange.settings.snippets.snippetsEnabled) {
      StackExchange.using("snippets", function() {
      createEditor();
      });
      }
      else {
      createEditor();
      }
      });

      function createEditor() {
      StackExchange.prepareEditor({
      heartbeatType: 'answer',
      autoActivateHeartbeat: false,
      convertImagesToLinks: true,
      noModals: true,
      showLowRepImageUploadWarning: true,
      reputationToPostImages: 10,
      bindNavPrevention: true,
      postfix: "",
      imageUploader: {
      brandingHtml: "Powered by u003ca class="icon-imgur-white" href="https://imgur.com/"u003eu003c/au003e",
      contentPolicyHtml: "User contributions licensed under u003ca href="https://creativecommons.org/licenses/by-sa/3.0/"u003ecc by-sa 3.0 with attribution requiredu003c/au003e u003ca href="https://stackoverflow.com/legal/content-policy"u003e(content policy)u003c/au003e",
      allowUrls: true
      },
      onDemand: true,
      discardSelector: ".discard-answer"
      ,immediatelyShowMarkdownHelp:true
      });


      }
      });














      draft saved

      draft discarded


















      StackExchange.ready(
      function () {
      StackExchange.openid.initPostLogin('.new-post-login', 'https%3a%2f%2fsuperuser.com%2fquestions%2f993152%2fgetting-tp-link-wn722n-to-work-on-rpi-openwrt%23new-answer', 'question_page');
      }
      );

      Post as a guest















      Required, but never shown

























      2 Answers
      2






      active

      oldest

      votes








      2 Answers
      2






      active

      oldest

      votes









      active

      oldest

      votes






      active

      oldest

      votes









      0














      It doesn't create the file to avoid configuration overlapping.



      You must append on the file the detected configuration.



      Use: wifi detect > /etc/config/wireless instead.



      Hope it helps others.






      share|improve this answer


























        0














        It doesn't create the file to avoid configuration overlapping.



        You must append on the file the detected configuration.



        Use: wifi detect > /etc/config/wireless instead.



        Hope it helps others.






        share|improve this answer
























          0












          0








          0






          It doesn't create the file to avoid configuration overlapping.



          You must append on the file the detected configuration.



          Use: wifi detect > /etc/config/wireless instead.



          Hope it helps others.






          share|improve this answer












          It doesn't create the file to avoid configuration overlapping.



          You must append on the file the detected configuration.



          Use: wifi detect > /etc/config/wireless instead.



          Hope it helps others.







          share|improve this answer












          share|improve this answer



          share|improve this answer










          answered Jun 15 '16 at 15:33









          CuSSCuSS

          15017




          15017

























              0














              did you insert the usb into a different usb slot? regarding option path: the 5 in the 1.5 is the usb slot id. if you pulled it out of the initial one, and put it into another slot, then you would need to manually update that to the new id. There may be a cli/shell command to do this, and perhaps that what the previous answer by CuSS would achieve with wifi detect > /etc/config/wireless






              share|improve this answer


























                0














                did you insert the usb into a different usb slot? regarding option path: the 5 in the 1.5 is the usb slot id. if you pulled it out of the initial one, and put it into another slot, then you would need to manually update that to the new id. There may be a cli/shell command to do this, and perhaps that what the previous answer by CuSS would achieve with wifi detect > /etc/config/wireless






                share|improve this answer
























                  0












                  0








                  0






                  did you insert the usb into a different usb slot? regarding option path: the 5 in the 1.5 is the usb slot id. if you pulled it out of the initial one, and put it into another slot, then you would need to manually update that to the new id. There may be a cli/shell command to do this, and perhaps that what the previous answer by CuSS would achieve with wifi detect > /etc/config/wireless






                  share|improve this answer












                  did you insert the usb into a different usb slot? regarding option path: the 5 in the 1.5 is the usb slot id. if you pulled it out of the initial one, and put it into another slot, then you would need to manually update that to the new id. There may be a cli/shell command to do this, and perhaps that what the previous answer by CuSS would achieve with wifi detect > /etc/config/wireless







                  share|improve this answer












                  share|improve this answer



                  share|improve this answer










                  answered Feb 7 '18 at 23:44









                  Mark PetersonMark Peterson

                  101




                  101






























                      draft saved

                      draft discarded




















































                      Thanks for contributing an answer to Super User!


                      • Please be sure to answer the question. Provide details and share your research!

                      But avoid



                      • Asking for help, clarification, or responding to other answers.

                      • Making statements based on opinion; back them up with references or personal experience.


                      To learn more, see our tips on writing great answers.




                      draft saved


                      draft discarded














                      StackExchange.ready(
                      function () {
                      StackExchange.openid.initPostLogin('.new-post-login', 'https%3a%2f%2fsuperuser.com%2fquestions%2f993152%2fgetting-tp-link-wn722n-to-work-on-rpi-openwrt%23new-answer', 'question_page');
                      }
                      );

                      Post as a guest















                      Required, but never shown





















































                      Required, but never shown














                      Required, but never shown












                      Required, but never shown







                      Required, but never shown

































                      Required, but never shown














                      Required, but never shown












                      Required, but never shown







                      Required, but never shown







                      Popular posts from this blog

                      Plaza Victoria

                      In PowerPoint, is there a keyboard shortcut for bulleted / numbered list?

                      How to put 3 figures in Latex with 2 figures side by side and 1 below these side by side images but in...